Recently, I was researching samba connections, and noticed that the Linux 'Domain Users' group was displaying as the Unix GID number instead of the name. I went to login to the admin-server express from '' and that page loads but when I click on the link I get.


Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

Apache/2.2 Server at Port 9830

So I went over to the 389 Management Console on my Windows box and I enter cn=Directory Manager the password and and I get a message saying the URL is not correct or the server is not running. For kicks and giggles I tried it with http instead of https and it gives an error that says,
"Cannot logon because of an incorrect User ID, Incorrect password, or Directory problem. HTTP response timeout"
Which indicates to me that the correct protocol should be https:

To further verify this I ran the following command at the Linux CLI on the server and a server that communicates with it.
ldapsearch -H ldaps:// [-x] -b o=netscaperoot -D "cn=directory manager" -W "objectclass=nsAdminConfig"
This returns 129 responses, but I don't know if they are valid or make sense. They look like they are unique to my system.

Here is a pastbin of some error logs I noticed after I restarted the admin server with stop-ds-admin and start-ds-admin.
#357156 • Fedora Project Pastebin

Job Cacka