Finally I got it  I don't know whether I did it the fully correct way, but it works now.
I found that this mysterious replica id 3 was stored in dse.ldif of my server-b:

To recap my scenario:

      server A     < -----       server B           <----->        server C            ----->    server D

(dedicated Consumer)     (multiple Master replica ID:1)    (multiple Master replica ID:2)  (Dedicated Consumer)

I wanted to promote my server D to become a multiple master - but it did not work.

What did I do to get it going:

1. Removed all replication agreements to/from server D.
2. Stopped all LDAP services on all servers (I was a little desperate)
3. Found replica id 3 in dse.ldif of server B(?) - nowhere else (why B and not C?)
4. Removed these bogus entries.
5. Restarted all LDAP services on all machines.
6. ldapsearch on server C still revealed the bogus replica id 3 (Where the heck is that cached?).
7. Reinitialized consumer server C from server B and restarted ldap on server C.
8. ldapsearch was clean by then.
9. removed my suffix on server D and removed changelog.
10. recreated suffix on server D and made server D a dedicated consumer
11. on server C created replication agreement to server D
12. initialized server D from server C.
13, Enabled changelog on server D
14. Changed server D to be Multiple Master with replica id 3
15, Created replication aggreement to server C from server D.
16. Worked. Restarted LDAP on server D and C.
17. Still works and replicates to all other machines along the path.
18. I need vacation....

Holy Moly!



Hi Reinhard,

Thanks for your reply!!

389-users-bounces@lists.fedoraproject.org wrote on 14.07.2011 16:25:10:

> From: Reinhard Nappert <rnappert@juniper.net>

> To: "General discussion list for the 389 Directory server project."
> <389-users@lists.fedoraproject.org>

> Date: 14.07.2011 16:28
> Subject: Re: [389-users] Replication trouble when promoting
> dedicated Consumer to Multiple master

> Sent by: 389-users-bounces@lists.fedoraproject.org
> Do a   ldapsearch -b 'nsuniqueid=ffffffff-ffffffff-ffffffff-
> ffffffff,dc=mydomain,dc=com' -D <directory manager> -w <password> -s
> base objectclass=nstombstone

> This gives you all the configured (history) of replication ids. The
> following is the output in my setup.

> dn: nsuniqueid=ffffffff-ffffffff-ffffffff-ffffffff,o=base
> objectClass: top
> objectClass: nsTombstone
> objectClass: extensibleobject
> nsds50ruv: {replicageneration} 4df7a107000000010000
> nsds50ruv: {replica 1 ldap://yale:389} 4df7a396000000010000 4e19ad950000000100
>  00
> nsds50ruv: {replica 3 ldap://norquay:389} 4df7a39d000000030000 4e1605650000000
>  30000
> nsds50ruv: {replica 4 ldap://mustrum:389} 4df7a3a0000000040000 4dfb93650000000
>  40000
> nsds50ruv: {replica 2 ldap://louise:389} 4df7a39a000000020000 4e171a0700000002
>  0000
> o: base
> nsruvReplicaLastModified: {replica 1 ldap://yale:389} 00000000
> nsruvReplicaLastModified: {replica 3 ldap://norquay:389} 00000000
> nsruvReplicaLastModified: {replica 4 ldap://mustrum:389} 00000000
> nsruvReplicaLastModified: {replica 2 ldap://louise:389} 00000000

>                                                   /\
>                                                    |
>                                              replication-id
I issued that command on my server Server C. I get the following results:

# extended LDIF
# LDAPv3
# base <nsuniqueid=ffffffff-ffffffff-ffffffff-ffffffff,dc=mydomain,dc=com> with scope baseObject
# filter: objectclass=nstombstone
# requesting: ALL

# ffffffff-ffffffff-ffffffff-ffffffff, mydomain.com
dn: nsuniqueid=ffffffff-ffffffff-ffffffff-ffffffff, dc=mydomain,dc=com
objectClass: top
objectClass: nsTombstone
objectClass: extensibleobject
nsds50ruv: {replicageneration} 4bf162c6000000010000
nsds50ruv: {replica 2 ldap://server-c.mydomain.com:389} 4cd3fa1e00000002
 0000 4e1ef45b000000020000
nsds50ruv: {replica 3 ldap://server-d.mydomain.de:389}
nsds50ruv: {replica 1 ldap://server-b.mydomain.de:389} 4bf16732000000010
 000 4e1ffa3e000000010000
dc: mydomain
nsruvReplicaLastModified: {replica 2 ldap://server-c.mydomain.com:389} 4
nsruvReplicaLastModified: {replica 3 ldap://server-d.mydomain.de:389} 00000000
nsruvReplicaLastModified: {replica 1 ldap://server-b.mydomain.de:389} 4e

# search result
search: 2
result: 0 Success

# numResponses: 2
# numEntries: 1

When I look at it I see that replica id 3 is assigned to my server-d
(which should get that replica id). I started over deleted my server-d
assigned it replica id 4 but nothing changes.

I also cannot get rid of the informations for server-d in that nsuniqueid
how can I do that?