On 12/29/2014 12:05 AM, Brooks Hu wrote:

Thanks for the help. 

Regarding my configuration file, i just copied it from other thus some lines wrong, but i think they have nothing to do with this issue. This issue should only be related to disk partitioning.

Are you certain that anaconda is finding the kickstart file (checked the server logs)?  There were two issues pointed out before:

  4) [!] Software selection (Nothing selected) 
  5) [!] Installation Destination (No disks selected)

Since it did not know which Software was selected (%packages in the kickstart) or the Installation Destination (specified as sda in the kickstart), it may not be finding the kickstart at all, or may not be able to successfully parse it.  Is it also possible that the initrd does not include all the requisite drivers to find the network or disk.  Please inspect the anaconda logs to see what errors are occurring.  From the shell window you can also verify that the network is functional (use curl to get the kickstart file), and check that the expected partitions are available.

I tried your kickstart configuration, but the issue still exists. I noticed in the configuration there is a line "bootloader --location=mbr", does it mean you are using legacy BIOS rather than EFI? I am using EFI BIOS.

I am using EFI as well.  Please be sure you are using the most recent firmware version.

I downloaded the image from here

then setup a local FTP to host it.

RC7 should be a good release to install, so I suspect is it an issue in the setup as mentioned above.


Best Regards,

On Mon, Dec 29, 2014 at 9:19 AM, David A. Marlin <dmarlin@redhat.com> wrote:
On 12/27/2014 06:19 PM, Brooks Hu wrote:

---------- Forwarded message ----------
From: Brooks Hu <brooks.hu@gmail.com>
Date: Friday, December 26, 2014
Subject: Help!Failed to find a suitable stage1 device when using PXE installation.
To: arm@lists.fedoraproject.org

Hi all,

I am trying automatic PXE installation (Fedora 21 for AARCH64) on my Mustang board, but looks like kickstart can't work. 

Here comes the detail:

Starting installer, one moment...
find_file: stat /proc/device-tree/chosen/bootpath, No such file or directory
anaconda 21.48.21-1 for Fedora-Server 21 started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2
 * when reporting a bug add logs from /tmp as separate text/plain attachments
10:26:29 Not asking for VNC because of an automated install
Starting automated install......
Generating updated storage configuration
storage configuration failed: failed to find a suitable stage1 device

 1) [x] Language settings                 2) [!] Timezone settings
        (English (United States))                (Timezone is not set.)
 3) [x] Installation source               4) [!] Software selection
        (                 (Nothing selected)
 5) [!] Installation Destination          6) [x] Network configuration
        (No disks selected)                      (Wired (eth0) connected)
 7) [!] Root password                     8) [!] User creation
        (Password is not set.)                   (No user will be created)
Not enough space in filesystems for the current software selection. An additional 2861.02 MiB is needed.
  Please make your choice from above ['q' to quit | 'b' to begin installation |
UEFI version is 1.1.0-rh-0.13

Here comes the kick start config file(I modified based on a sample from certain website):

Note that the installation options indicate: 4) [!] Software selection (Nothing selected) and 5) [!] Installation Destination (No disks selected), which implies anaconda is not seeing (or accepting) some of the options in your kickstart.  Please look in the logs in /tmp to find any errors.

There are some things in you kickstart that I am not familiar with, such as:

  vznetcfg --net=virt_network1:eth0
  vztturlmap $FS_SERVER http://myrepository.com
  %eztmplates --cache

and the following just look wrong for an aarch64 install:


I would try a more "standard" Fedora kickstart install first to make sure the repos, etc. are working, and then try adding the 'custom' config options to see what breaks.

Attached is an example kickstart I have successfully used for provisioning a Mustang board.


lang en_US.UTF-8
keyboard us
part efi --fstype=efi --size=300 --ondisk=sda
part /boot --fstype=ext4 --size=512 --ondisk=sda
part / --fstype=ext4 --size=20096 --ondisk=sda
part /vz --fstype=ext4 --size=40768 --ondisk=sda
part swap --size=4000
bootloader --location=partition --ondisk=sda
network --bootproto dhcp
rootpw root
auth --enableshadow --passalgo=sha512
timezone --utc America/New_York
vznetcfg --net=virt_network1:eth0
vztturlmap $FS_SERVER http://myrepository.com
%eztmplates --cache


I have tried all kinds of option combination, also deleted all the partitions, but it still can't work. Any suggestions/comments are welcomed!

Best Regards,

arm mailing list

arm mailing list