Here are some fixes and cleanups caught by inspecting code and/or compiling
by new compilers.
Cheers,
Vita
Vitezslav Samel (11):
packet.c: simplify in_cksum() and rename it to verify_ipv4_hdr_chksum()
verify_ipv4_hdr_chksum(): remove unneded check
ifstats.c: simplify destroyiflist()
bugfix: detstats(), ifstats(): handle packets with incorrect header checksum
bugfix: positionptr(): properly allocate dynamicly created interfaces
packet_get(): optimization
build: use wide version of -lpanel when needed
ifaces.c: fix duplicate 'const' declaration specifier warning
iptraf.c: fix "use of uninitialized variable" warning
packet.c: fix "use of uninitialized variable" warning
centralize IPv4 fragment handling
Makefile | 22 ++++++++++++++--------
src/detstats.c | 18 ++++++++++--------
src/ifaces.c | 2 +-
src/ifaces.h | 2 +-
src/ifstats.c | 53 +++++++++++++++++++++++++++++------------------------
src/ipfrag.c | 6 +++---
src/ipfrag.h | 20 ++++++++++++++++++++
src/iptraf.c | 9 +++------
src/itrafmon.c | 8 ++------
src/packet.c | 33 +++++++++++++--------------------
10 files changed, 96 insertions(+), 77 deletions(-)
--
1.7.8.4