Here are some fixes and cleanups caught by inspecting code and/or compiling
by new compilers.
Cheers,
Vita
v1 -> v2: drop ipfrag changes (will be done later)
Vitezslav Samel (10):
packet.c: simplify and rename in_cksum() to verify_ipv4_hdr_chksum()
verify_ipv4_hdr_chksum(): remove unneded check
ifstats.c: simplify destroyiflist()
bugfix: detstats(), ifstats(): handle packets with incorrect header checksum
bugfix: positionptr(): properly allocate newly created interfaces
packet_get(): optimization
build: use wide version of -lpanel when needed
ifaces.c: fix warning
packet.c: fix "use of uninitialized variable" warning
iptraf.c: fix "use of uninitialized variable" warning
Makefile | 22 ++++++++++++++--------
src/detstats.c | 18 ++++++++++--------
src/ifaces.c | 2 +-
src/ifaces.h | 2 +-
src/ifstats.c | 53 +++++++++++++++++++++++++++++------------------------
src/iptraf.c | 9 +++------
src/packet.c | 29 ++++++++++-------------------
7 files changed, 68 insertions(+), 67 deletions(-)
--
1.9.1