* Ralf Corsepius (rc040203(a)freenet.de) wrote:
On Mon, 2005-10-31 at 00:33 -0500, Chris Wright wrote:
> -Requires: rsync, rcs, curl, less, openssh-clients, python >= 2.3, tk >= 8.4
> +Requires: zlib >= 1.2, rsync, rcs, curl, less, openssh-clients, python >=
2.3, tk >= 8.4
Adding "Requires: zlib >= 1.2" hardly makes sense.
The package's dependencies on libz.so.* are automatically being pulled
in, which will always work unless zlib should screw up it's SONAMES.
I guess you wanted "BuildRequires: zlib-devel >= 1.2"
It builds fine, and has internal macros to handle zlib-devel < 1.2.
It's runtime that fails (apparently, I haven't recreated this myself,
it was reported by someone running older distro). But git-core uses
zlib's *Bound functions which seem to have been introduced in the
.so w/out bumping any library version (between zlib 1.1 and zlib 1.2).
So RPM creates implicit requirement on libz.so.1, which is satisified on
machine that has either zlib 1.1 or zlib 1.2. However will fail during
runtime with the former. So it seems that zlib >= 1.2 is best way to
handle that. What do you think?